I'm using an unsupported browser

Follow

Harver's technology is supported by the most up to date versions of Google Chrome, Mozilla Firefox, and Safari, but it depends on the device you are currently using.

I’m using my mobile/tablet

Depending on your mobile device and operating system we support different browsers. Please see below the overview and make sure your browser app is fully up to date:

  • iOS (iPhone and iPad)

    • Safari (minimum version v13)

  • Android

    • Google Chrome (minimum version v80) (recommended)

    • Mozilla Firefox (minimum version v85)

    • Samsung Internet (minimum version v14)

I’m using my desktop/laptop computer

On laptop/desktop (Window or Mac platforms) Live Video Interview supports:

  • Google Chrome (minimum version v80) (recommended)

  • Safari (minimum version v13)

  • Mozilla Firefox (minimum version v89)

  • Microsoft Edge (minimum version v89)

If you aren't sure if you are running the most recent version of these browsers, you may update your browser using the links below:

Update Google Chrome

Update Mozilla Firefox

Update Safari

I don't know which browser I’m using

If you're not sure what browser you're using, you can check it via What browser am I using?.

Disclaimer: Harver is not affiliated in any way ‘whatsmybrowser.org’.

 
 
Was this article helpful?
10 out of 15 found this helpful